No specified parameters for web service execution

Nov 30, 2010 at 5:39 PM

Hello...I'm back :)

Was working on adding the automatic removal of a workstation from a collection, and after fixing some minor issues it appeared to be working just from watching the TS steps on the client.  Checking the server showed that was not the case, and that workstations were still left in their collection.  I pulled the log files and saw right away what the problem was...

ZTI_ExecuteWebService.log:
Using DEFAULT VALUE: Ini file = C:\_SMSTaskSequence\WDPackage\Scripts\CustomSettings.ini CHECKING the [RemoveComputerFromCollection] section No valid specified for parameter 'MACADDRESS', web service results could be unpredictable. No valid specified for parameter 'UUID', web service results could be unpredictable. No valid specified for parameter 'OSDCOMPUTERNAME', web service results could be unpredictable.
~~~~
About to execute web service call using method POST to http://myservername/SCCMWebService/sccm.asmx/RemoveComputerFromCollection: macAddress=&UUID=&CollectionID=0850000E&ComputerName=

I'm a little stumped on the matter, because it is obviously reading the CS.ini enough to know the web address to query, but it isn't getting workstation variables (though it is getting the collectioID)? My smsts.log is showing the following, which seems to indicate at least some things are ok:

Site code: 085	
Client machine name: 020-410-12S
Client Identity: GUID:2159CF7C-1CF7-43A1-A7FC-BDB3DFB25F96

 

My CS.ini looks like this:

[Settings] 
Priority=Initialize,GetSCCMAssignedSite,Default
Properties=AssignedSite,CurrentOSDCollectionID

[Initialize]


[Default]
AssignedSite=085

[GetSCCMAssignedSite]
WebService=http://myservername/SCCMWebService/AD.asmx/GetSCCMAssignedSite
AssignedSite=string


[RemoveComputerFromCollection] 
WebService=http://myservername/SCCMWebService/sccm.asmx/RemoveComputerFromCollection 
Parameters=macAddress,UUID,CurrentOSDCollectionID,OSDComputerName 
CurrentOSDCollectionID=CollectionID 
OSDComputerName=ComputerName


[ClearLastPXEAdvertisementForComputer] 
WebService=http://myservername/SCCMWebService/sccm.asmx/ClearLastPXEAdvertisementForComputer 
Parameters=macAddress,UUID,AssignedSite 
AssignedSite=SiteCode

I'm not sure where the disconnect is...BDD.log is showing the same as ZTI_ExecuteWebService.log.  Is there something I need to call beforehand to populate these fields?  I thought this was done automatically?  My TS is reporting that it is completing successfully, but the lack of proper parameters allows it to work not as intended.  Incidentally, I have the same issue when trying to call the ClearLastPXEAdvertisementForComputer service...except that I also have an entry for no valid parameter for ASSIGNEDSITE.

Would it help to post more of my logs?  Any help would be greatly appreciated! Thanks!

PS--my TS right now simply has steps to include the MDT Toolkit, and the two web service calls...I have it like that for testing purposes.

Nov 30, 2010 at 9:21 PM

I think I found the problem...I was not aware that I needed to have a Gather step (yes, I'm a MDT script nub).  The TS is now removing the computer from the appropriate collection, though I'm having minor difficulties with clearing the PXE flag, but I believe it can be overcome easily.

Dec 1, 2010 at 4:28 PM

You are right. I should have pointed this out a bit more clearly. If you would like to use information like MacAddress, UUID, etc your best choice is to have a gather step at the beginning (or at least after the latest reboot). Or you have to write a script that reads those values and writes the appropriate settings. Well, it's a waste of time so use gather ;-).

I have to admit that I actually never use pure ConfigMgr OSD TaskSequences since I got used to MDT. I always integrate MDT and use the MDT Templates as they give me so many advantages above the default behaviour that I tend to miss those points ;-)

So glad you figured it out yourself

Regards

Maik

Dec 1, 2010 at 9:21 PM

No worries, Maik :)  Your blog has been a very valuable resource for me! Thanks so much!

As I said earlier, the only problem I'm having now with this is getting the PXE flag cleared because there's nothing getting set for the AssignedSite parameter...I've tried using the AD web service call, as well as hard coding it under [Default] (as shown above), but I still get the message stating that there was no valid parameter.  I may try to hard code it into the actual script file instead and see if that makes a difference :P

Dec 6, 2010 at 7:16 PM

Haha, ok...maybe I just can't stay away from here :)

In either case, I've not been able to resolve the issue with clearing the last PXE flag...same deal with the invalid parameter.  As before, it isn't getting my site code...I've specified it in my CS.ini file under the [Default] heading, as well as with the AD call to get the side code.  I've tried setting the order different in the priority under [Settings] (ie, just Default, just GetSCCMAssignedSite, both, and one before the other).  Is there something else I'm missing here?  I know that earlier the problem was that I had to add a gather step...is there something along these lines that I'm not considering?  Thanks!

Dec 14, 2010 at 3:56 PM

Was re-tracing my steps for this and found the issue...thought I had specified a rules file for my gather step, but I hadn't enabled it >.<

*sigh*