Custom Boot Wizard confusion

Mar 4, 2011 at 12:40 PM
Edited Mar 4, 2011 at 1:49 PM

Hi all

I'm slightly [or perhaps that should be 'very') confused. Tried to write this out fully so apolgises for the long post but hope you good good people can find time to read through it :)

Been looking at the custom boot wizard and have started making something up with it and the results are 50/50 good and bad really.

Just to explain the situation, we are already using SCCM OS deployment and using this WebService for a few things such as using it to add a computer to a specific collection etc.

Because I cant really stop what's currently setup (as a bunch of staff will not be able to do deploy new Win7 machines) I'm trying to make this Custom Boot Wizard in a testing Collection environment to keep things neatly out of the way.

Following this:

The boot image seems to work fine, and I was going to move the MDT Wizard off of the boot disk to help speed up testing, but the files attached on article mentioned in the above one, are no longer downloadable unfortunately, so I've had to stick with the imagex mounting and unmounting technique to update the scripts as I tweak them, then updating the boot image so the changes are distributed to the DP's :)

I'm just using the default files in the Custom Boot Wizard download - obviously tweaked where it say to - and I've also had a little look at the CustomBootWizard files too using the handy MDT Wizard Editor - changed a bit of text thats displayed, but nothing that would break anything :)

I'm currently a bit stuck/confused with two issues.....

Issue/Confusion 1:
Because we have the OS deployment setup and working using the normal WinPE / SCCM boot image, i've made this custom boot wizard boot image, and have advertised it with PXE enabled to a new test collection, then added a test computer resource to this collection (one already known to SCCM) and used "Hidden" in the Description on other collections that have PXE / OSD TS's on them so that dont appear. I've left out Hidden from one collection that has a Task Sequence attached to it (the one currently being used by the techies to deploy Win7 at the moment) in order for it to display in the custom boot wizard.

The test machine boots using this custom boot image, and I eventually get the HTA GUI appear - looking correct with my little tweaks :) -  but unfortunately now showing any Collections / Task Sequences listed i.e. i get "No Operating Systems are available for this site. Please contact your local IS Support." displayed.

The confusion here  I've run into is that the OS deployment Task Sequences themselves shouldnt have a boot image attached to them (in this setup) otherwise the machine just boots into that boot image rather than our specificly advertised custom boot image, but both the OSD TS and the Custom Boot Image TS advertisements need to be "available to PXE".... correct? Or am I muddled?

(remember, i cant stick it on Unknown Computers / All Systems until i've finished it etc, as cant interrupt the existing TS's and setups)

Edit: forgot to add that even though the resource computer is attached to both the Custom Boot Wizard and the Win7 Test Collection's, and neither have Hidden in the description of the Collection, neither are listed when booting into that machine via the custom boot image :S

Also, while I can use the WebService directly aka pointing to it in a browser, I dont get anything when I try and GetOSDCollections test invoke.... I just get:


  <?xml version="1.0" encoding="utf-8" ?> 
  <ArrayOfCollection xmlns:xsi="" xmlns:xsd="" xmlns="" /> 

in the resulting page, and thats it. Which is a bit odd considering I'm running that as me, and I've got full access across SCCM (being i set it up etc).


Issue/Confusion 2:

er.... I'll come back to it... I've got a bit of a mental block now and I need to pop out :)



Mar 10, 2011 at 4:02 PM

No takers? A shame... (btw, have no idea now what Issue 2 is.... issue 1 is irritating me enough as it is hehe)

Great project btw, but still missing steps for people who, like me, are starting from complete scratch.

However, for the sake of it, I'll point to where I'm at now.

- Still cant find any way to get the webservice query SCCM to show me a list of collections / advertisements / or anything along those lines (note again that the webservice does work as we've been using it since Sept/Oct with Win7 RTM and I've been able to get it to manipulate AD and/collections in that it places the resource object in the right place, although I switched to getting it to place the object into a AD group and have the collection query that, but I digress).

- In case it was something "fruity" with the CustomBootWizard, I've basically tried switching to using the PrettyGoodFrontEndClone (as thats more what we are after in the first place), have barely adjusted anything, although I have managed to get the boot menu files out of the boot image so that I dont have to recreate that constantly (via THIS LINK)

- Got more of a picture of how things work, but still seems pot luck with certain things

Anyone got any sort of idea how to get it to give you the list collections or is it some sort of manual file only and I've just been missing the mark on understanding it somehow?


Mar 11, 2011 at 3:50 PM

On confusion 1: Please take a look the the bdd.log file at X:\MININT\SMSOSD\OSDLOGS . It should tell you more about what is going on, especially how the web service gets called. It migth be a missing SiteCode or something similar. If the wizard does not show any problems/Error in its logs, you could also check the logs on the server side. The most current versions write a quite extensive log if required (see for details).



Mar 11, 2011 at 4:43 PM

Thanks Maik....but already been looking at the things you suggested for the past week hehe ;)

You've beat me to posting my progress this afternoon though :)

Here's what I've found this afternoon:

- Didnt realise it, but I was running 7.1 - i guess at that time I started this last year, it was around October so must have got the version before you put up 7.2 and I didnt commit the version number to memory so just saw Oct 2010 and thought no new version yet (feature idea: have the version number showing when you browse with a browser to the asmx scripts perhaps ;)), but anyhow, I've brought it up to 7.2 but no apparent difference.

- Tried all manner of different things and permissions to try and get it to work, and at long last, something I've done this afternoon must have helped as I'm happily able to get, for example, the list of Collections that have a advertised OSD TS when I manually browse to http://.../SCCM.asmx?op=GetOSDCollections

Looking at the OSD Logs has no real errors in them now on the target machine (i'm using a VM for speed) but unfortunately, it still seems to not find any advertised OSD's according to the logs, which isnt correct, as firing up a portable Firefox that i've got in the boot image and browsing to the same location above shows me the same list as it did on my machine confusingly.

Bear in mind I'm trying to use the PrettyGoodFrontEndClone as it has the core of what i wanted, and will customise it when i can get it to work ;) I've (probably incorrectly) replaced the Wizard.hta in the Boot Menu / Scripts folder by deleting it and renaming the the PGFEC's Frontend.hta and Frontend.wsf to Wizard.hta and Wizard.wsf, and have put the settings in the customsettings.ini into the SCCM_Bootstrap.ini (that i had from the CBW). All seems to look correct, but I guess I must be overlooking something somewhere :(

The real puzzler(s) i see in the BDD.log is right at the end of it where it says:

File: OUList.xml Line: 0 - The system cannot locate the object specified.
File: RoleList.xml Line: 0 - The system cannot locate the object specified.
File: ComputerRoleList.xml Line: 0 - The system cannot locate the object specified.
File: TaskSequenceList.xml Line: 0 - The system cannot locate the object specified.

and earlier on in the log where I have:

FindFile: The file x86\Microsoft.BDD.Utility.dll could not be found in any standard locations.
FindFile(..\Microsoft.BDD.Utility.dll) Result : 1
FindFile: The file x86\Microsoft.BDD.Utility.dll could not be found in any standard locations.
FindFile(..\Microsoft.BDD.Utility.dll) Result : 1
RUN: regsvr32.exe /s ""
FAILURE (Err): 429: CreateObject(Microsoft.BDD.Utility) - ActivX component can't create object.

Not sure what the findfile one is all about... made the boot image in the proper way via SCCM etc and then mounted/unmounted it to tie in the ZTIMediaHook as described earlier in the thread (so its pointing to a share for the actual scripts and saving a huge amount of time thankfully).

Any ideas what I'm missing? Might just try the Custom Boot Wizard again now and see what that does.

Mar 12, 2011 at 12:36 AM

would you mind sending me the log files to maik dot koster at gmx dot de or store them at some skrydrive or similar so I can have a look.



Mar 17, 2011 at 5:36 PM

Hi Maik

I started compiling the logs from a PXE Custom Boot Wizard process to show you, and then I had a bit of a thought....

I had used frontend.hta from the PGFEC and replaced the normal wizard.hta with it. Putting the normal MDT Wizard.hta back again now gives me Task Sequences :)

However, I'm not quite sure how to proceed from here.

Are you meant only edit the CustomBootWizard.xml file to customise the HTA? How do i use / where do I put the code that i need from the FrontEnd.hta?

Additionally, after selecting the TS, i still get up getting the normal Welcome screen (where you put the administrator password if set, or if not set, just click next) and then still have to choose the TS (of which, I only get the Boot Wizard Only TS that you create).

I do have "SkipBDDWelcome=YES" in my SCCM_bootstrap.ini file in the boot menu. Do I just need some additional Skip.... settings in there too? (thats what I'm going to try next while I await your response in the meantime)