Problems adding computer to collection

Jun 23, 2011 at 2:20 PM

First I wanted to say thank you for the awesome product.

I have had MDT Web Service running for quite some time now along with the Custom Boot Wizard.  Recently, I noticed that some PC's will not add to the colleciton properly.  These are usually PC's that are currently in SCCM and need a re-image.

When Custom boot Wizard runs, it indicates that is adds the PC to the collection.  Looking at the collection membership, I see a direct rule with the name it assigned.  When looking at the SCCM console though, the PC shows in that collection with name Unknown.  Because of this, the pc never recieves the Task Sequence advertised to that collection.

I'm not sure where to start troubleshooting.  Any help would be greatly appreciated.

MDTWeb IsComputerKnown returns true

HasOSDAdvertisement returns true

GetComputerName returnes unknown

Membership Rules

SCCM Console

Coordinator
Jul 11, 2011 at 12:58 PM

That's actually a bug in the function, adding computers to a collection. It was caused if the computer couldn't be found by MAC and/or UUID. Then the function would try to create a new computer record with the supplied information. But it would fail to add the new record if another record with the same name exists already. Anyway, on the download page you will find the most recent Beta bits that should fix this issue. The new version will be published within the next couple of days.

Regards

Maik

Sep 27, 2011 at 5:39 PM

Maik,

Love the webservices they are very handy, but we are seeing the exact same problem as listed above and I confirmed we are running the most recent downloads. Are there beta downloads that I missed? Or something else we can do before hand to help limit/prevent this issue from occuring?

 

Logs/data/anything you need please let me know and I'll provide it.

Again thanks for the hard work on these.

-OSE