DeploymentWebservice - Works Perfectly for AD, but not for MDT or SCCM!

Feb 18, 2013 at 5:30 PM
Edited Feb 18, 2013 at 5:31 PM
Hi Maik/All,

Absolutely love the WebService and other MDT bits you have done, so thank you very much for those :-)

I am however having a slight issue with using the WebService from an MDT and SCCM point of view. I've installed the WebService (correctly to the best of my knowledge!) and the AD bit of it is working a treat... The MDT/SCCM bit however I am not having much luck with :-/
Through the web page, if I try to invoke one of the operations, such as GetRoles, it simply returns a blank page. I've looked through the logs and can see no errors/warning messages. I'm guessing it's something really dopey I'm doing (or not doing!) with permissions etc but for the life of me cannot work it out! Any pointers as to where I could start looking?

I have tried it with 'MDTDBIntegratedSecurity' set to 'True' which should work because the account to the best of my knowledge has permissions. I have also tried manually defining the 'MDTDBUser' and 'MDTDBPassword' fields using my personal domain credentials which I use everyday for my work with MDT and still no difference.

Any help would be hugely appreciated!!

Kind Regards,

Feb 19, 2013 at 11:53 AM
Edited Feb 19, 2013 at 11:56 AM
Hi All,

Figured it out now, I was being a plonker!

For some reason, I'd completely neglected to do the StoredProcedure part so obviously the MDT sections of the WebService was going to return a blank! I used the SQL script at the bottom of the following page to execute the stored procedures against the MDT database.

And then information from this page to troubleshoot the fact that I had the incorrect database selected in the DB field in the top right of the SQL query window;

The script executed succesfully with some warnings, related to fields which didn't exist. I'm guessing this is down to the fact that I'm using MDT 2012 Update 1, and the SQL Script was probably written for a earlier version with slightly different field names. But other than the missing fields it worked a treat :-)

The only issue is on the Documentation pages for the Deployment WebServices, the section about adding the StoredProcedures is appearing blank? Probably why I completely overlooked it in the first place...!

Perhaps Maik you could replace the info on this page if you get two mins?

Again, thank you so much for all the hard work you have done with the Deployment WebServices, WebFrontEnd etc, they're fab projects and make my life a whole world easier!

Kind Regards,