Custom Boot Wizard - no TS selection

Nov 12, 2010 at 4:45 PM

Hello,

I sent Maik a message about this, and later realized I probably should have come here first.  In either case, I've setup the Custom Boot Wizard with the web services portion per the step-by-step guide in his blog.  Everything looks to be working correctly...if I access the web front end, I can run the various queries (such as GetOSDAdvertisements) and they report correctly.  Upon using PXE to access the new custom boot wizard, I get the dos prompt showing that it is running the ZTI scripts per the media hook.  The MDT wizard pops up, asks for the workstation name, and then I am prompted to select which TS I would like to run.  Everything seems to be working, right?  Well unfortunately the only available TS shown is my custom boot wizard.  I made sure that "hidden" was in the comment section for the TS, as my first thought was that it was displaying only TS's that had been "hidden", but quickly ruled that out as there were a few others that were hidden as well.  So with my custom boot wizard as the only option to select, I click ok, "Applying operating system" pops up but quickly disappears as that step is disabled, and then the workstation restarts.  Has anyone else run into this problem?

As a side note, in my IIS application I did not specify any MDTDB variables for the web service settings, as I did not think I needed them, but I also don't know what they would be as I don't use MDT.  Are those MDTDB settings still required even if I don't use it?

Thanks for any help on the matter!

Nov 12, 2010 at 8:02 PM

Interestingly enough, I decided to checkout the SCCM_Bootstrap.ini located at X:\Deploy\Scripts\ and found that it only contained:

[Settings]
Priority=Default

[Default]
SkipWizard=NO

I mounted the image and checked out the folder for the scripts, and for whatever reason, it looks like it did not replace the files with the ones for the boot wizard. Being as I'm not sure how the files didn't make it there to begin with, I manually replaced them and will be updating and testing the image soon...

Nov 12, 2010 at 9:59 PM

After mounting the image and manually adding the scripting files to the wim, I am now getting farther than before, though still with errors...I'll have to dig around more when I come to work on Monday.  It also helps now that there are log files I can reference for the web front end piece.

Nov 15, 2010 at 4:30 PM

Ok, we're a step in the right direction but still not there.  The command prompt shows the commands being sent to the web service, getting the site code, and (supposedly) successfully completing the HasOSDAdvertisement call (at least it returns as true when I run it manually from a browser)...but when asked to select a task sequence to run I'm still limited to my "Boot Wizard Only" TS!  Why is it that this is the only TS showing up?  GetOSDAdvertisement returns a full list of TS's when I run it from a browser...

Nov 19, 2010 at 11:16 AM

The wizard typically calls GetOSDCollections to present you with a list of Collections that have an OSD Task Sequence advertised. To "hide" certain Task Sequences (especially the Boot Wizard only should be hidden!) add the word "Hidden" to the Description of any of those collections. With the newest version of the Webservice you can also use other functions that can use different keywords for explict include or exclude (GetOSDCollectionsFiltered). So call "GetOSDCollections" for the specified primary and see what Collections you get back. That will be the list presented by the wizard on default.

Regards

 

Maik

Nov 19, 2010 at 3:15 PM
Edited Nov 19, 2010 at 3:30 PM

Ack...just found a grevious error on my part...will respond soon...

 

[edit2]

I realized that I had been adding "hidden" to my TS and not the collections...which would explain some of my problems.

Nov 19, 2010 at 5:40 PM

I'm not sure what was changed to get this to start working, as I had let it be since my post on the 12th and hadn't changed anything since then. However, this morning when I booted up the workstation, it was now displaying two collections for OSD...go figure.

As noted, I had been adding "hidden" to my TS comments, BUT I had forgotten that I had also added "hidden" to the collection properties of my other collections where I had non-mandatory TS.  These collections were later used for mandatory TS, which I expected to see on the list, but didn't (for now obvious reasons).  When I changed one of the two collections that I WAS getting in the wizard, I went back to double check the other collections, which is where I found my mistake.

They are all reporting fine now...just wish I knew why the wizard wasn't progressing earlier, like it is now.  After thinking about it, the only real change I would have made would have been when I updated the boot image with some drivers for a new network card...who knows?  Maybe updating the DP's again helped?

Next step is to work on having the TS automatically remove the workstation from the collection ^_^

Thanks for all your work Maik...I really enjoy your articles!