Error GetGroupMembers

Aug 12, 2011 at 5:12 PM
Edited Aug 12, 2011 at 5:14 PM

I'm getting this error when i try to run GetGroupMembers when quarrying for MDT_Group group in AD:

 

System.Runtime.InteropServices.COMException: The specified domain either does not exist or could not be contacted.

   at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
   at System.DirectoryServices.DirectoryEntry.Bind()
   at System.DirectoryServices.DirectoryEntry.get_AdsObject()
   at System.DirectoryServices.PropertyCollection.Contains(String propertyName)
   at MaikKoster.Deployment.AD.Controller.ContainsAttribute(String attributeName, DirectoryEntry Entry)
   at MaikKoster.Deployment.AD.Controller.GetAttributeValuesObject(String attributeName, String ObjectDN)
   at MaikKoster.Deployment.AD.Controller.GetGroupMembers(String ObjectDN)
   at MaikKoster.Deployment.WebService.AD.GetGroupMembers(String Groupname)

 

The log file seems to show that it found the domain controller (mydomain.com) and is using the correct credentials (ADAccount)

 

2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.WebService.AD|Creating new instance of Active Directory webservice. Current version is 7.2.0.85
2011-08-12 11:55:49.2149|INFO|MaikKoster.Deployment.WebService.AD|Reading configuration
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.WebService.AD|Specified Domain is mydomain.com
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.WebService.AD|Specified Username is ADAccount
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.WebService.AD|Creating new AD Controller
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.AD.Controller|Created new controller Instance for Domain mydomain.com using credentials for User ADAccount.
2011-08-12 11:55:49.2149|INFO|MaikKoster.Deployment.WebService.AD|Requested member of Group MDT_Group with their distinguisded name
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.AD.Controller|Get distinguished name for Group "MDT_Group" on Server "
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.AD.Controller|Get Directory Entry for ObjectDN "".
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.AD.Controller|No ObjectDN supplied. Using Domain mydomain.com.
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.AD.Controller|Getting Directory Entry for object mydomain.com using configured credentials for user ADAccount.
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.AD.Controller|Added LDAP:// to supplied Path "mydomain.com"
.2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.AD.Controller|Preparing AD Search.
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.AD.Controller|Search Root is "LDAP://mydomain.com".
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.AD.Controller|Executing query "(&(objectClass=group)(|(cn=MDT_Group)(distinguishedName=MDT_Group)))".
2011-08-12 11:55:49.2149|DEBUG|MaikKoster.Deployment.AD.Controller|Found object at path LDAP://mydomain.com/CN=MDT_Group,OU=Groups,OU=IT,OU=Deparment,DC=mydomain,DC=com. Get Directory Entry.
2011-08-12 11:55:49.2259|DEBUG|MaikKoster.Deployment.AD.Controller|Found distinguished name "CN=MDT_Group,OU=Groups,OU=IT,OU=Deparment,DC=mydomain,DC=com".
2011-08-12 11:55:49.2259|DEBUG|MaikKoster.Deployment.AD.Controller|Get list of members in Group "CN=MDT_Group,OU=Groups,OU=IT,OU=Deparment,DC=mydomain,DC=com".
2011-08-12 11:55:49.2259|DEBUG|MaikKoster.Deployment.AD.Controller|Get list of values for attribute "member" of object "CN=MDT_Group,OU=Groups,OU=IT,OU=Deparment,DC=mydomain,DC=com".
2011-08-12 11:55:49.2259|DEBUG|MaikKoster.Deployment.AD.Controller|Get Directory Entry for ObjectDN "CN=MDT_Group,OU=Groups,OU=IT,OU=Deparment,DC=mydomain,DC=com".
2011-08-12 11:55:49.2259|DEBUG|MaikKoster.Deployment.AD.Controller|Getting Directory Entry for object CN=MDT_Group,OU=Groups,OU=IT,OU=Deparment,DC=mydomain,DC=com using configured credentials for user ADAccount.
2011-08-12 11:55:49.2259|DEBUG|MaikKoster.Deployment.AD.Controller|Added LDAP:// to supplied Path "CN=MDT_Group,OU=Groups,OU=IT,OU=Deparment,DC=mydomain,DC=com".

Aug 25, 2011 at 8:11 AM

Could you please post/send me the next couple of lines of the log?

Maik

Sep 6, 2011 at 4:19 PM

Sorry for the late reply, I found out the issue was a permissions problem and nothing to do with the script